Jump to content

C4 Grand Picasso EGS gearbox problems.


Recommended Posts

hello all, not been here in years but ive now got another picasso so im back, and im coming in straight away with a problem. 

fair warning, you may want to grab a cuppa as this posts going to be long :)

firstly my car is a 2008 C4 Grand Picasso 1.6HDi VTR+ with the 'Semi-Auto' piloted Manual 6 speed gearbox

the start of this issue was when the clutch started slipping badly and i was getting a oil leak of some sort from the car.

pulled the gearbox(which is a pain in and of itself) and removed the remains of the clutch, which was very dead as the clutch plate had seperated into 2 pieces.

fitted new clutch and and refitted gearbox. ran through the full gearbox programming procedure in diagbox(lexia on this car only shows 2 control units for some reason) and i believe it succeded. . clutch dag setting definately succeded.

this new clutch lasted LESS THAN 300 MILES before it got completely cooked.

again removed the box and clutch. removed the release bearing from gearbox and discovered that the main inpute shaft bearing had collapsed in the box - so that explains the severe oil leak.

replaced the complete gearbox from a donor car and swapped my gearbox ecu over to it just incase. replaced clutch with a brand new Sachs unit. 

now from this point onwards the clutch seems to be permanently engaged. it does NOT release and the gearbox input shaft speed always matches the engine rpm. 

ive had the box out a further 5 times now checking things, first i checked clutch was mounted correctly as it seems the c4 is backwards to most cars in that the flat side of the clutch plate goes towards the gearbox. ?

second i changed the release bearing with a known good.

third put the ecu originally from the donor box on

forth checked clutch again .

fifth changed electropump assembly.

always the same issue and i CANNOT successfully run the clutch calibration in either diagbox or delphi diagnostics, it always fails 

 

any ideas appreciated as im now completely baffled - im pretty good with mechanical stuff and electrics and have recently done a full 5 to 6 speed gearbox conversion on my audi a4 without problem. this ****** "semi-auto" box is driving me nuts.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...